Accueil / Articles / PrestaShop / PrestaShop 1.5

PrestaShop 1.5

PrestaShop 1.5, version tant attendue depuis plus d’un an, est officiellement sortie le 13/09/2012.

Cette première version stable (version 1.5.0.17) offre de nombreuses fonctionnalités très intéressantes, une des plus importantes étant la gestion de multi-boutiques depuis un même back-office.

Nouvelle installation

L’installation de la version 1.5.0.17 de PrestaShop sur un site “vierge” s’est parfaitement déroulée.

Mise à jour

Avec le module autoupgrade version 0.8 proposé par PrestaShop, je n’ai eu aucun mal à migrer une boutique qui était en version 1.4.9.0 (installation neuve strictement d’origine, pour le test) vers la version 1.5.0.17

Faut-il passer à PrestaShop 1.5 ou rester à une version antérieure ?

Je vais continuer dans les prochains jours à tester cette nouvelle version majeure de PrestaShop et je complèterai cet article.

Ma première impression est que cette version est très intéressante, ou du moins prometteuse. Pour un nouveau site, je ne verrais pas d’objection à démarrer un projet avec cette version 1.5

Par contre, pour un site déjà existant en version 1.4, je conseillerais d’attendre quelques semaines, histoire d’avoir un peu de recul sur la stabilité de cette première version 1.5. Il y a forcément des petits problèmes qui vont apparaître, qui seront réglés par d’autres releases mineures. Mais rien n’interdit pendant ce temps de tester (en local par exemple) une migration d’un site 1.4 actuel, afin de vérifier par exemple la compatibilité de ses modules ou thèmes.

Et vous, quelles sont vous opinions ? Vous sentez-vous prêt à passer à la version 1.5 ? Ou restez vous quelques temps encore en version 1.4 ? N’hésitez pas à poster vos commentaires pour faire part de votre expérience !

Avec du recul

(Ce qui suit est écrit fin janvier 2017)

La version 1.5 de PrestaShop est donc maintenant bien ancienne. Hormis une mise à jour faite durant l’été 2015 pour corriger un problème très particulier, PrestaShop 1.5 n’a pas été mis à jour depuis janvier 2014.

Si cette version a connu des début assez difficiles et m’ont coûté quelques nuits blanches, elle s’est avérée à partir de 2013 être assez stable.

J’ai encore un certain nombre de clients qui utilisent cette version. Cependant, j’essaie de les sensibiliser au fait que, comme elle n’est plus maintenue, ils sont susceptibles d’être exposés à certains failles ou de rencontrer quelques bugs corrigés sur les versions suivantes.

A ceux qui désirent donc mettre leur version 1.5 à jour, j’explique aussi qu’en l’état actuel de PrestaShop 1.7 (version 1.7.0.4 au moment où j’écris ces lignes), il est absolument inconcevable et irresponsable de migrer vers PS 1.7 ! Trop de bugs, des fonctionnalités absentes (plus de module Paypal !!!), et beaucoup d’incompatibilités dues à l’utilisation dorénavant du framework PHP Symfony (ce qui est en soit pourtant une bonne chose).

Le plus raisonnable est donc de passer en PrestaShop 1.6, branche qui sera supportée par l’éditeur jusqu’en octobre 2018, et qui nécessite moins d’effort lors de la mise à jour depuis PrestaShop 1.5. Les modules sont en général compatibles, les thèmes aussi, mais la plupart de mes clients en version 1.5 n’avaient pas de thème reponsive, donc on en profite pour se mettre au goût du jour aussi à ce niveau là 🙂

 

Voir aussi

Génération de références pour PrestaShop

Si pour des raisons de logistique, vous devez utiliser des références produits pour votre catalogue …

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.